Friday, July 24, 2015

Connecting two virtualbox VMs with GNS3



This is a simple lab shows you how to connect virtualbox VMs with Gns3.





Picture above show the scenario connecting virtualbox with gns3. Router R1 connecting virtual machine XP1 and router R2 connecting virtual machine XP2.

Configuration of R1

R1#conf t
R1(config)#int fastEthernet 0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no sh
R1(config-if)#exit
R1(config)#int fastEthernet 0/1
R1(config-if)#ip address 10.0.0.1 255.255.255.252
R1(config-if)#no sh
R1(config-if)#exit

Ospf configuration of R1
R1(config)#router ospf 10
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
R1(config-router)#network 10.0.0.0 0.0.0.3 area 0

Configuration of R2
R2#conf t
R2(config)#int fastEthernet 0/1
R2(config-if)#ip address 10.0.0.2 255.255.255.252
R2(config-if)#no sh
R2(config-if)#exit
R2(config)#int fastEthernet 0/0
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#no sh
R2(config-if)#exit

Ospf configuration of R2
R2(config)#router ospf 15
R2(config-router)#network 192.168.2.0 0.0.0.255 area 0
R2(config-router)#network 10.0.0.0 0.0.0.3 area 0


                                                      watch below video





Tuesday, January 27, 2015

NAT OVERLOAD CONFIGURATION WITH GNS3

             Here is the lab for the configuration of NAT overload configuration with GNS3


The first step to deploy NAT is to define NAT inside and outside interfaces. You may find it easiest to define your internal network as inside, and the external network as outside.Below layout serial S1/0 of R2 will be inside port and f0/0 will be the outside port.







This is a simple lab configuration  about how to configure Nat Overload with GNS3 router.
Here i am using two vmware virtual networks VMnet 2 and VMnet3 to connect gns3 with external
networks. In the above picture cloud 1 represented as public internet and it configured with NAT.
Host1 machine is connected to VMware virtual machine with help of VMnet3.


Configuration of R1

R1#conf t
R1(config)#int fa0/0
R1(config-if)#ip address 192.168.0.1 255.255.255.0
R1(config-if)#no sh
R1(config-if)#exit
R1(config)#int serial 1/0
R1(config-if)#ip address 10.10.1.1 255.255.255.252
R1(config-if)#no sh
R1(config)#ip route 0.0.0.0 0.0.0.0 10.10.0.2
R1(config)#exit

Configuration of R2

R2#conf terminal
R2(config)#int serial 1/0
R2(config-if)#ip address 10.10.0.2 255.255.255.252
R2(config-if)#ip nat inside
R2(config-if)#no sh
R2(config-if)#exit
R2(config)#int fastEthernet 0/0
R2(config-if)#ip address 192.168.137.10 255.255.255.0
R2(config-if)#no sh
R2(config-if)#ip nat outside
R2(config-if)#exit
R2(config)#ip route 192.168.0.0 255.255.255.0 10.10.0.1
R2(config)#ip route 0.0.0.0 0.0.0.0 192.168.137.2
R2(config)#ip nat inside source list 1 interface fastEthernet 0/0 overload
R2(config)#access-list 1 permit 192.168.0.0 0.0.0.255
R2(config-if)#exit

                                                              watch below video